Zing Touch: ILX now ON IPHONE (and ipod tooches too)

Message Bookmarked
Bookmark Removed
Not all messages are displayed: show all messages (1795 of them)

Yes, it’s going to be a setting in the next version

stet, Tuesday, 10 December 2019 10:09 (two years ago) link

Omg you shlda warned me how amazing update was gonna be. Wuv wuv wuv

nathom, Tuesday, 10 December 2019 17:32 (two years ago) link

looks so nice!!

call all destroyer, Wednesday, 11 December 2019 11:33 (two years ago) link

a niggle - occasionally when composing, dragging the cursor to the beginning of the post, or maybe just elsewhere in the compose window, erases all the text!

Li'l Brexit (Tracer Hand), Wednesday, 11 December 2019 12:17 (two years ago) link

Wow, I’ve never seen that! Does a double tap with three fingers and pressing the undo arrow (on iOS 13) or shaking (on iOS 12) bring it back?

stet, Wednesday, 11 December 2019 13:06 (two years ago) link

just tried and no. can be hard to replicate but try swiping with one finger fairly quickly pretty much anywhere in the compose window after entering some text.

Li'l Brexit (Tracer Hand), Wednesday, 11 December 2019 13:13 (two years ago) link

Got it! It doesn’t erase the text for me but it does make the keyboard vanish. I’ll investigate

stet, Wednesday, 11 December 2019 13:15 (two years ago) link

Sorry to report I’m running into some problems in the new version:
During search the screen goes blank when entering the search term. Search results show up, but won’t link through when selected. It then gets stuck on the results screen for ages, with no apparent way out, making the app temporarily unusable.

Also, embedded tweets won’t link through to the source tweet on Twitter directly in many (most?) cases, unlike before.

I’m on iOS 12, as noted upthread.

breastcrawl, Saturday, 14 December 2019 18:15 (two years ago) link

What device are you using, breastcrawl? I'll take a look

I've also confirmed there's a bug with polls which means you can't vote for an option - fixing now

stet, Saturday, 14 December 2019 18:21 (two years ago) link

iPhone 6

breastcrawl, Saturday, 14 December 2019 18:29 (two years ago) link

Hey Stet in night mode the text in the search box comes up black so it’s invisible. It worked fine, just had to type carefully.

Tim, Saturday, 14 December 2019 22:28 (two years ago) link

Not sure it’ll make it out from Apple before Christmas, but a bug fix version has been sent to them.

Fixes almost everything mentioned here - poll voting, twitter links, the search colour*, edited text vanishing, etc. (Can’t reproduce what you’re seeing breastcrawl but will keep looking!)

* this is still broke after you have just changed colour, close and reopen app to fix.

stet, Sunday, 22 December 2019 10:58 (two years ago) link

thanks stet. fingers crossed...

breastcrawl, Sunday, 22 December 2019 13:38 (two years ago) link

two weeks pass...

+1 on the bug where a bunch of stuff gets erased when composing and the keyboard goes blank (grey) for a minute when doing selecting, cutting and pasting. Basically, when it comes back, I have an earlier version of the text I’d been working on. I don’t normally mention bugs but this one is pretty bad in that it prevents much in the way of editing longer posts.

I’m on 13.3 and an XS in night mode.

Naive Teen Idol, Saturday, 11 January 2020 15:14 (two years ago) link

Yeah, it was terrible, sorry: the version fixing it is waiting for review with Apple now

stet, Thursday, 16 January 2020 21:42 (two years ago) link

ime (13.3/iPhone8), threads that are polls do not show poll results when you select them through search

willem, Friday, 17 January 2020 09:12 (two years ago) link

Yeah, that's right. Tricky to fix, that -- I'll see if I can come up with something.

stet, Friday, 17 January 2020 17:56 (two years ago) link

stet = ledge

lefal junglist platton (wtev), Friday, 17 January 2020 21:38 (two years ago) link

Two things I’ve noticed:

* Trying to vote in a poll results in immediate crash. 100% reproducible.
* Links to other ILX thread now launch the web version in a browser, and requires login.

I use an iPhone X (13.3)

beard papa, Friday, 17 January 2020 22:07 (two years ago) link

yeah, they're both fixed now

stet, Friday, 17 January 2020 23:40 (two years ago) link

... in the new version which is rolling out now

stet, Saturday, 18 January 2020 00:34 (two years ago) link


calstars, Saturday, 18 January 2020 00:40 (two years ago) link


Disco Cladistic (James Redd and the Blecchs), Saturday, 18 January 2020 01:08 (two years ago) link


breastcrawl, Saturday, 18 January 2020 12:30 (two years ago) link

... in the new version which is rolling out now

testing again

breastcrawl, Saturday, 18 January 2020 12:31 (two years ago) link

Thanks, stet. My appraisal:

All Twitter links do open again, yay! In most cases they don’t link through to the Twitter app itself, unlike before-before, but I’ll take it.

Poll voting works again (voted cashew!).

The search function is still fucked for me though, both in dark and light mode:

-I can’t see what I’m writing
-search results do show up, and can be sorted
-but when I click on the result of my liking it doesn’t link me through
-worst of all, I can’t leave the results page to go back or move on and do something else. The page is stuck there. All I can do is sit it out and try the app again at some later point, hoping that by then it has decided it’s time to refresh itself.

(Apparently this is a problem only I have. Will have to continue to do my searching on Safari, I guess)

breastcrawl, Saturday, 18 January 2020 12:36 (two years ago) link

Je déteste tout, our very own French-language board, seems to be partly Zing-incompatible. Its main thread, 'Nous voilà enfin débarrassés de tous ces amateurs', apparently comes with 'some old or corrupted messages ... which Zing can't read'. Quite the indictment.

pomenitul, Saturday, 18 January 2020 12:42 (two years ago) link

As I tried to edit my earlier post (which I wrote outside the app) within the app I experienced a brand new problem:
I couldn’t scroll down/navigate in the text I had prepared to get to the bottom section that wasn’t immediately visible.
Also, it seems you have to actively clear previous texts from memory or else it overrules the reply function.

Is this just me again? (iPhone6/12.4.4)

Now I want my old Zing back...

breastcrawl, Saturday, 18 January 2020 12:51 (two years ago) link

This is super-odd. I wonder if it’s an iOS 12 issue. Madchen has one of those, I’ll test on hers.

stet, Saturday, 18 January 2020 13:09 (two years ago) link

Yes, I see the scroll issue I think. The search is working though. Huh.

stet, Saturday, 18 January 2020 13:10 (two years ago) link

I'm too poor to be deemed worthy of iOS 13, so that may well be it.

pomenitul, Saturday, 18 January 2020 13:11 (two years ago) link

I am on iOS 13 and have the zing problem with 'Nous voilà enfin débarrassés de tous ces amateurs'

juntos pedemos (Euler), Saturday, 18 January 2020 13:55 (two years ago) link

Having the scroll issue too, I’m on iOS 13.3.

steer karma (gyac), Saturday, 18 January 2020 19:39 (two years ago) link

Yeesh, found that and fixed it. New version going live now. Sorry!

stet, Monday, 27 January 2020 01:55 (two years ago) link

some questions since I'm playing around with development tools to pick up a few things and decided to make a rudimentary ilx client as a test:

1. is the 'api' that Zing uses the only api available? it seems like the login is the ootb login page and then you get the cookies for the rest of the requests
2. the rest of the calls are just xml versions of threads/posts. is that right?
3. all auth is via cookies?

my initial idea was to recreate the backend and gui in one app but to speed things up (since I'm learning all the frontend stuff on the fly) I was going to wrap all the existing API calls in a modern rest api returning json but... hrrm

babu frik fan account (mh), Tuesday, 28 January 2020 02:19 (two years ago) link

I can return JSON if that’s what you prefer but yeah it’s the auth etc that will cause all the grief. What platform are you building for?

stet, Tuesday, 28 January 2020 09:59 (two years ago) link

nbd really! just curious

If that sounds about right, I’ll see how long my attention span lasts in experimenting. I was messing around in Flutter/Dart and was going to do a quick c# backend (something I have existing experience in) to get things rolling faster.

babu frik fan account (mh), Tuesday, 28 January 2020 13:49 (two years ago) link

four months pass...

hey is there like a bug submission type thing if we find a thread that gives a "Problem reading messages" error saying that Zing can't read old/corrupted messages? it's this one btw: Maurice Fulton...best tunes by him

vision joanna newsom (Stevie D(eux)), Wednesday, 10 June 2020 19:55 (two years ago) link

You can start a thread on Mod Request, but I'll sort this one, thanks

stet, Wednesday, 10 June 2020 21:25 (two years ago) link

Should be sorted now.

Also, mh: now have a non-cookie-based version of the auth API, if you're still playing about

stet, Wednesday, 10 June 2020 21:27 (two years ago) link

my home coding is all work-related now but that’s cool news!

mh, Thursday, 11 June 2020 15:47 (two years ago) link

one month passes...

Just curious why the app prevents you from pinching / resizing images ?

calstars, Monday, 13 July 2020 20:18 (two years ago) link

It’s not so much that it prevents it, it’s more than I don’t know how to enable it! Time to copy and paste random things from StackOverflow dot com again

stet, Tuesday, 14 July 2020 11:24 (two years ago) link

update on my search problem:

at some point I discovered that search actually does work fine for me when I do it on the bookmarks page. the issue I described back in Dec and Jan is with searching on
one of the board pages. so basically I’m good as long as I think before I search.

No mean feat. DaBaby (breastcrawl), Tuesday, 14 July 2020 17:18 (two years ago) link

one month passes...

New version going out now with support for hidden text

and experimental styling in posts

stet, Tuesday, 18 August 2020 16:40 (two years ago) link

  • l
  • m
  • a
  • o

𝔠𝔞𝔢𝔨 (caek), Tuesday, 18 August 2020 21:42 (two years ago) link

one month passes...

Hey, stet, poss. I missed this upthread but are you aware poll results aren’t showing? Not the end of the world as I can pull them up on Safari and I’m not sure if it’s only a problem with older threads. But I’ve noticed it a bunch when searching through various poll threads of late.

Naive Teen Idol, Wednesday, 7 October 2020 11:27 (two years ago) link

Have you got some examples, please? All the ones I've looked at so far are working OK for me

stet, Wednesday, 7 October 2020 11:48 (two years ago) link

I'm thinking it may be the same issue reported earlier:

ime (13.3/iPhone8), threads that are polls do not show poll results when you select them through search

― willem, Friday, January 17, 2020 10:12 AM (eight months ago) bookmarkflaglink

Yeah, that's right. Tricky to fix, that -- I'll see if I can come up with something.

― stet, Friday, January 17, 2020 6:56 PM (eight months ago) bookmarkflaglink

willem, Wednesday, 7 October 2020 12:48 (two years ago) link

ahhh shit yes, that remains tricky

stet, Wednesday, 7 October 2020 12:49 (two years ago) link

You must be logged in to post. Please either login here, or if you are not registered, you may register here.