Zing Touch: ILX now ON IPHONE (and ipod tooches too)

Message Bookmarked
Bookmark Removed
Not all messages are displayed: show all messages (1789 of them)

cosign with DJI - also if you tap a Twitter post on e.g. the image, any linked video won't link correctly, but if you tap on the date of the post, it loads correctly and you can tap through to the video or images linked.
A small thing too - when shifting day-to-night and vice versa using standard type appearance, the big headlines stay in the colour of the old mode (i.e. they stay white, on a light background, or black on a dark background). If it was possible for Zing to switch to night mode when the phone does so, that would be awesome, but maybe break things for folks not on iOS 13.
Offered only in the spirit of wanting to help, not complaint - it's a great app!

an incoherent crustacean (MatthewK), Saturday, 30 November 2019 00:37 (two years ago) link

As others have said, I'd have been happy to pay for this upgrade.

Heavy Messages (jed_), Saturday, 30 November 2019 00:44 (two years ago) link

this is a gift that keeps on giving

Irae Louvin (James Redd and the Blecchs), Tuesday, 3 December 2019 15:11 (two years ago) link

Challops version going to Apple, fixing:
- Lines are back between messages
- Orientation bug is fixed at last
- Twitter videos now play inside the message view(!)
- And stop playing when you leave the view

I can't fix the dark/light switch not changing the headlines without dropping iOS 12 support (as far as I can tell) and there are way too many people still not on iOS 13 yet.

stet, Thursday, 5 December 2019 00:53 (two years ago) link

(Thanks for being lovely, everyone)

stet, Thursday, 5 December 2019 00:54 (two years ago) link

Thank you stet!

DJI, Thursday, 5 December 2019 00:59 (two years ago) link

Are pics supposed to autoload? I see little picture frames that I have to click on.

Cow_Art, Thursday, 5 December 2019 01:17 (two years ago) link

twitter videos playing within zing is a very exciting development

call all destroyer, Thursday, 5 December 2019 01:31 (two years ago) link

right. won’t miss the workaround for that

Irae Louvin (James Redd and the Blecchs), Thursday, 5 December 2019 02:01 (two years ago) link

Yes @CowArt

DJI, Thursday, 5 December 2019 02:27 (two years ago) link

stet if you wanna make a gofundme or a Patreon I'm there

an incoherent crustacean (MatthewK), Thursday, 5 December 2019 04:55 (two years ago) link


dan selzer, Thursday, 5 December 2019 12:10 (two years ago) link


chet san telmo (alomar lines), Saturday, 7 December 2019 15:10 (two years ago) link

4.1 is rolling out now with all those fixes above, plus you can now sort search results and search within just one board.

(Challops: you can no longer filter just the threads on a New Answers, but that'll come back)

stet, Monday, 9 December 2019 23:48 (two years ago) link

Very very slick update stet, the attention to detail is impressive

an incoherent crustacean (MatthewK), Tuesday, 10 December 2019 05:43 (two years ago) link

Great job - justr a minor thing: any way to reinstate the "XX hours/days ago" time stamp beneath posts?

licorice oratorio (baaderonixx), Tuesday, 10 December 2019 09:50 (two years ago) link

Yes, it’s going to be a setting in the next version

stet, Tuesday, 10 December 2019 10:09 (two years ago) link

Omg you shlda warned me how amazing update was gonna be. Wuv wuv wuv

nathom, Tuesday, 10 December 2019 17:32 (two years ago) link

looks so nice!!

call all destroyer, Wednesday, 11 December 2019 11:33 (two years ago) link

a niggle - occasionally when composing, dragging the cursor to the beginning of the post, or maybe just elsewhere in the compose window, erases all the text!

Li'l Brexit (Tracer Hand), Wednesday, 11 December 2019 12:17 (two years ago) link

Wow, I’ve never seen that! Does a double tap with three fingers and pressing the undo arrow (on iOS 13) or shaking (on iOS 12) bring it back?

stet, Wednesday, 11 December 2019 13:06 (two years ago) link

just tried and no. can be hard to replicate but try swiping with one finger fairly quickly pretty much anywhere in the compose window after entering some text.

Li'l Brexit (Tracer Hand), Wednesday, 11 December 2019 13:13 (two years ago) link

Got it! It doesn’t erase the text for me but it does make the keyboard vanish. I’ll investigate

stet, Wednesday, 11 December 2019 13:15 (two years ago) link

Sorry to report I’m running into some problems in the new version:
During search the screen goes blank when entering the search term. Search results show up, but won’t link through when selected. It then gets stuck on the results screen for ages, with no apparent way out, making the app temporarily unusable.

Also, embedded tweets won’t link through to the source tweet on Twitter directly in many (most?) cases, unlike before.

I’m on iOS 12, as noted upthread.

breastcrawl, Saturday, 14 December 2019 18:15 (two years ago) link

What device are you using, breastcrawl? I'll take a look

I've also confirmed there's a bug with polls which means you can't vote for an option - fixing now

stet, Saturday, 14 December 2019 18:21 (two years ago) link

iPhone 6

breastcrawl, Saturday, 14 December 2019 18:29 (two years ago) link

Hey Stet in night mode the text in the search box comes up black so it’s invisible. It worked fine, just had to type carefully.

Tim, Saturday, 14 December 2019 22:28 (two years ago) link

Not sure it’ll make it out from Apple before Christmas, but a bug fix version has been sent to them.

Fixes almost everything mentioned here - poll voting, twitter links, the search colour*, edited text vanishing, etc. (Can’t reproduce what you’re seeing breastcrawl but will keep looking!)

* this is still broke after you have just changed colour, close and reopen app to fix.

stet, Sunday, 22 December 2019 10:58 (two years ago) link

thanks stet. fingers crossed...

breastcrawl, Sunday, 22 December 2019 13:38 (two years ago) link

two weeks pass...

+1 on the bug where a bunch of stuff gets erased when composing and the keyboard goes blank (grey) for a minute when doing selecting, cutting and pasting. Basically, when it comes back, I have an earlier version of the text I’d been working on. I don’t normally mention bugs but this one is pretty bad in that it prevents much in the way of editing longer posts.

I’m on 13.3 and an XS in night mode.

Naive Teen Idol, Saturday, 11 January 2020 15:14 (two years ago) link

Yeah, it was terrible, sorry: the version fixing it is waiting for review with Apple now

stet, Thursday, 16 January 2020 21:42 (two years ago) link

ime (13.3/iPhone8), threads that are polls do not show poll results when you select them through search

willem, Friday, 17 January 2020 09:12 (two years ago) link

Yeah, that's right. Tricky to fix, that -- I'll see if I can come up with something.

stet, Friday, 17 January 2020 17:56 (two years ago) link

stet = ledge

lefal junglist platton (wtev), Friday, 17 January 2020 21:38 (two years ago) link

Two things I’ve noticed:

* Trying to vote in a poll results in immediate crash. 100% reproducible.
* Links to other ILX thread now launch the web version in a browser, and requires login.

I use an iPhone X (13.3)

beard papa, Friday, 17 January 2020 22:07 (two years ago) link

yeah, they're both fixed now

stet, Friday, 17 January 2020 23:40 (two years ago) link

... in the new version which is rolling out now

stet, Saturday, 18 January 2020 00:34 (two years ago) link


calstars, Saturday, 18 January 2020 00:40 (two years ago) link


Disco Cladistic (James Redd and the Blecchs), Saturday, 18 January 2020 01:08 (two years ago) link


breastcrawl, Saturday, 18 January 2020 12:30 (two years ago) link

... in the new version which is rolling out now

testing again

breastcrawl, Saturday, 18 January 2020 12:31 (two years ago) link

Thanks, stet. My appraisal:

All Twitter links do open again, yay! In most cases they don’t link through to the Twitter app itself, unlike before-before, but I’ll take it.

Poll voting works again (voted cashew!).

The search function is still fucked for me though, both in dark and light mode:

-I can’t see what I’m writing
-search results do show up, and can be sorted
-but when I click on the result of my liking it doesn’t link me through
-worst of all, I can’t leave the results page to go back or move on and do something else. The page is stuck there. All I can do is sit it out and try the app again at some later point, hoping that by then it has decided it’s time to refresh itself.

(Apparently this is a problem only I have. Will have to continue to do my searching on Safari, I guess)

breastcrawl, Saturday, 18 January 2020 12:36 (two years ago) link

Je déteste tout, our very own French-language board, seems to be partly Zing-incompatible. Its main thread, 'Nous voilà enfin débarrassés de tous ces amateurs', apparently comes with 'some old or corrupted messages ... which Zing can't read'. Quite the indictment.

pomenitul, Saturday, 18 January 2020 12:42 (two years ago) link

As I tried to edit my earlier post (which I wrote outside the app) within the app I experienced a brand new problem:
I couldn’t scroll down/navigate in the text I had prepared to get to the bottom section that wasn’t immediately visible.
Also, it seems you have to actively clear previous texts from memory or else it overrules the reply function.

Is this just me again? (iPhone6/12.4.4)

Now I want my old Zing back...

breastcrawl, Saturday, 18 January 2020 12:51 (two years ago) link

This is super-odd. I wonder if it’s an iOS 12 issue. Madchen has one of those, I’ll test on hers.

stet, Saturday, 18 January 2020 13:09 (two years ago) link

Yes, I see the scroll issue I think. The search is working though. Huh.

stet, Saturday, 18 January 2020 13:10 (two years ago) link

I'm too poor to be deemed worthy of iOS 13, so that may well be it.

pomenitul, Saturday, 18 January 2020 13:11 (two years ago) link

I am on iOS 13 and have the zing problem with 'Nous voilà enfin débarrassés de tous ces amateurs'

juntos pedemos (Euler), Saturday, 18 January 2020 13:55 (two years ago) link

Having the scroll issue too, I’m on iOS 13.3.

steer karma (gyac), Saturday, 18 January 2020 19:39 (two years ago) link

Yeesh, found that and fixed it. New version going live now. Sorry!

stet, Monday, 27 January 2020 01:55 (one year ago) link

You must be logged in to post. Please either login here, or if you are not registered, you may register here.