Flagging is an ILX app for Android (in beta)

Message Bookmarked
Bookmark Removed

Have at it

Thrills! Spills! Bugs! Try it out and let me know if you have any issues. Requires entering your password, there just isn't a way around it. I don't do anything evil with it though.

If anyone can come up with a better icon - and really, anyone could come up with a better icon - let me know.

With help from diamonddave85, although he's not responsible for the bugs or the length of time it took.

0 / 0 (lukas), Tuesday, 21 February 2017 01:10 (two years ago) Permalink

wow, looks good and is very fast. nice!

Louder Than Borads (James Redd and the Blecchs), Tuesday, 21 February 2017 01:33 (two years ago) Permalink

doesn't seem to show one's post without explicitly refreshing though

Louder Than Borads (James Redd and the Blecchs), Tuesday, 21 February 2017 01:34 (two years ago) Permalink

Yeah, known issue, will fix.

0 / 0 (lukas), Tuesday, 21 February 2017 01:36 (two years ago) Permalink

been waiting a long time for this, thanks! tho is anyone else getting the weird bug where unclicked boards pop back up?

NI, Tuesday, 21 February 2017 02:00 (two years ago) Permalink

Needs a way to change background color, though.

Christine Green Leafy Dragon Indigo, Tuesday, 21 February 2017 02:07 (two years ago) Permalink

And I wish it could be moved on to an SD card.

Christine Green Leafy Dragon Indigo, Tuesday, 21 February 2017 02:09 (two years ago) Permalink

I haven't seen the issue with the boards. What phone / Android version?

I'll look into those other requests. The background color thing shouldn't be tough. Might do.something about the typeface as well although Android doesn't make it easy.

0 / 0 (lukas), Tuesday, 21 February 2017 02:22 (two years ago) Permalink

S7 Edge, Android 6.0.1. It doesn't seem to save the chosen boards correctly, keeps a few but adds a random bunch more.

NI, Tuesday, 21 February 2017 04:35 (two years ago) Permalink

Yeah I have something similar with the boards. In my case I only have ILM and ILE saved but I'm seeing a bunch of threads from other boards under New Answers. Also S7 Edge, Android 6.0.1.

heaven parker (anagram), Tuesday, 21 February 2017 07:51 (two years ago) Permalink

i am just another APPL stooge but I am very excited to see the fruition of all your

El Tomboto, Tuesday, 21 February 2017 08:58 (two years ago) Permalink

HTML Playground posts and etc

El Tomboto, Tuesday, 21 February 2017 08:58 (two years ago) Permalink

Great news!

Wozniak on Kimye's Baby (jaymc), Tuesday, 21 February 2017 14:00 (two years ago) Permalink

awesome, thanks

ciderpress, Tuesday, 21 February 2017 14:08 (two years ago) Permalink

Just updated to Android version 7 and all boards working fine now

NI, Tuesday, 21 February 2017 16:19 (two years ago) Permalink

Interesting. That shouldn't be ... will check out.

There are a few other known issues: sometimes will crash after coming back from a long sleep, and sometimes will get into a broken state when it fails to reach the server. Killing and restarting the app fixes.

0 / 0 (lukas), Tuesday, 21 February 2017 17:19 (two years ago) Permalink

Congrats lukas! Looks great

stet, Tuesday, 21 February 2017 21:40 (two years ago) Permalink

using this RN I like

The Perks of Being a Wall St R (darraghmac), Tuesday, 21 February 2017 21:51 (two years ago) Permalink

a few posts of mine didn't go through, will try again (on computer right now)

also they were shitposts tbh so no great loss

Islamic State of Mind (jim in vancouver), Tuesday, 21 February 2017 22:25 (two years ago) Permalink

Yeah posting was one of the last things to get added - I noticed today that for some reason Flagging can't post comments to the I Hate Apple thread. I'll look into but sorry if anyone loses deathless prose in the meantime :/

0 / 0 (lukas), Tuesday, 21 February 2017 22:43 (two years ago) Permalink

Dope

(•̪●) (carne asada), Tuesday, 21 February 2017 22:55 (two years ago) Permalink

nice

goole, Tuesday, 21 February 2017 22:58 (two years ago) Permalink

yeah my posts weren't going through just now either

ciderpress, Tuesday, 21 February 2017 23:12 (two years ago) Permalink

Just on the one thread?

0 / 0 (lukas), Tuesday, 21 February 2017 23:17 (two years ago) Permalink

submitted a test reply here a moment ago but it never arrived

art, Tuesday, 21 February 2017 23:20 (two years ago) Permalink

app is pretty slick otherwise tho

art, Tuesday, 21 February 2017 23:21 (two years ago) Permalink

Same question about phone and version of Android for you my friend

0 / 0 (lukas), Wednesday, 22 February 2017 00:17 (two years ago) Permalink

I post?

Islamic State of Mind (jim in vancouver), Wednesday, 22 February 2017 00:42 (two years ago) Permalink

Ah success

Islamic State of Mind (jim in vancouver), Wednesday, 22 February 2017 00:42 (two years ago) Permalink

I'm having trouble reproducing the phantom post thing, although I've seen it myself. Details helpful as mentioned above. I'll keep fiddling with it.

0 / 0 (lukas), Wednesday, 22 February 2017 01:47 (two years ago) Permalink

@lukas i use galaxy s6, android is version 6.0.1

art, Wednesday, 22 February 2017 02:16 (two years ago) Permalink

oh hey that was posted via the app

art, Wednesday, 22 February 2017 02:16 (two years ago) Permalink

Kind of a small annoyance but if I scroll halfway down the list of threads, open one, read it and then hit the Back button on my phone to return to the list, I'm returned to the top of the list rather than the point where I left off. If that could be fixed then great, if not no biggie.

heaven parker (anagram), Wednesday, 22 February 2017 09:45 (two years ago) Permalink

Is there a minimum Android version for this? Doesn't seem to work properly on my phone, for instance "I only have ILM and ILE saved but I'm seeing a bunch of threads from other boards under New Answers" - there's no obvious way to select which boards appear on New Answers, they're all there. I think I'm on 4.4.

Transform All Suffering Into Poo (Colonel Poo), Wednesday, 22 February 2017 09:49 (two years ago) Permalink

same on Android 7.1.2 , I can select and deselect boards with individual sliders and it remembers my choices but there's no effect on the post list (oh hey, I'm on 77? I don't remember if I knew that)

and I can reply to some posts but not others.

StanM, Wednesday, 22 February 2017 10:05 (two years ago) Permalink

The board issue will be a quick fix. Still hoping to find a way to reproduce the posting issue.

0 / 0 (lukas), Wednesday, 22 February 2017 16:34 (two years ago) Permalink

u r my hero

Al Moon Faced Poon (Moodles), Wednesday, 22 February 2017 16:42 (two years ago) Permalink

bookmarking a post in Flagging on my phone does not seem to carry over to the board on my PC

Al Moon Faced Poon (Moodles), Wednesday, 22 February 2017 16:43 (two years ago) Permalink

Some people report this with Zing too; this might not be Flagging-specific. If you can figure out lukas I'd love to know

stet, Wednesday, 22 February 2017 18:23 (two years ago) Permalink

Are there maybe different server/instance values I should use?

Al Moon Faced Poon (Moodles), Wednesday, 22 February 2017 18:37 (two years ago) Permalink

Fixed a silly problem with posting replies to threads, guessing this is the bug people are seeing. Also fixed seeing threads from disabled boards. Won't be able to push this update until tonight tho.

0 / 0 (lukas), Wednesday, 22 February 2017 20:40 (two years ago) Permalink

thankig u

StanM, Wednesday, 22 February 2017 21:30 (two years ago) Permalink

Wish I had an android just to try it!

calstars, Wednesday, 22 February 2017 21:33 (two years ago) Permalink

superb, thanks dude. instant ilx HOF

Roberto Spiralli, Wednesday, 22 February 2017 21:39 (two years ago) Permalink

hey I am posting this from Flagging works great!

blonde redheads have more fun (upper mississippi sh@kedown), Wednesday, 22 February 2017 21:41 (two years ago) Permalink

(terrible joke about disabled boards flagged automatically by app)

StanM, Wednesday, 22 February 2017 21:48 (two years ago) Permalink

trying this now!

kinder, Wednesday, 22 February 2017 22:17 (two years ago) Permalink

is there an easy way to quote posts or put in links?

kinder, Wednesday, 22 February 2017 22:19 (two years ago) Permalink

There will be in Flagging Pro, the non-free version :-)

StanM, Wednesday, 22 February 2017 22:23 (two years ago) Permalink

those are on the list, kinder

0 / 0 (lukas), Wednesday, 22 February 2017 23:21 (two years ago) Permalink

you dan't do this in Flagging, but in a browser go to Bookmarks. You can mass-delete bookmarks from there.

e-woke (NotEnough), Friday, 19 January 2018 14:15 (one year ago) Permalink

mookie's wording is a little confusing but I THINK what's being referred to is the bug discussed upthread, where on browsers on the same device, the top of SNA is piled high with pages and pages of "updated" bookmarks for threads you've long since caught up on in flagging or on your desktop. it's really weird tbh.

Righteous wax chaperone, rotating Wingdings (Doctor Casino), Friday, 19 January 2018 14:21 (one year ago) Permalink

yeah, this

mookieproof, Friday, 19 January 2018 17:22 (one year ago) Permalink

I have this issue on both flagging and regular ILX on my work computer. Don't have this on my phone or home computer.

Moodles, Friday, 19 January 2018 19:22 (one year ago) Permalink

for me, flagging is always up to date, but since I started using it, using ilx in-browser on my phone (really only necessary due to lack of search function, bookmark-browsing, and control-F) has been suffering this problem. super weird.

Righteous wax chaperone, rotating Wingdings (Doctor Casino), Friday, 19 January 2018 19:38 (one year ago) Permalink

Same, I just choose to use my chrome browser instead. Don't know what keeps it from syncing across devices. This was a problem before flagging.

Moodles, Friday, 19 January 2018 20:50 (one year ago) Permalink

Strangely, that doesn't happen with me at all- bookmarks sync perfectly across flagging/phone chrome/desktop chrome.

e-woke (NotEnough), Friday, 19 January 2018 22:20 (one year ago) Permalink

Yeah, same here.

ArchCarrier, Saturday, 20 January 2018 06:30 (one year ago) Permalink

a new wrinkle: flagging isn't picking up that i changed my display name over in browser land. or perhaps ilx isn't telling itself that the DN is different anywhere besides this phone's browser. but... why would that be?

if you steeleye spanshine (Doctor Casino), Wednesday, 24 January 2018 16:13 (one year ago) Permalink

^^^ that's me in browser, this is me in flagging

Righteous wax chaperone, rotating Wingdings (Doctor Casino), Wednesday, 24 January 2018 16:13 (one year ago) Permalink

oh no i've said too much

mookieproof, Wednesday, 24 January 2018 16:17 (one year ago) Permalink

AHA now I know what the bookmark problem is

stet, Wednesday, 24 January 2018 19:03 (one year ago) Permalink

lol mookie

Righteous wax chaperone, rotating Wingdings (Doctor Casino), Wednesday, 24 January 2018 19:52 (one year ago) Permalink

haha
choosing my display name

kinder, Wednesday, 24 January 2018 21:22 (one year ago) Permalink

three weeks pass...

Just wondering: why doesn't Flagging use the bookmark function to load threads? Very long threads (for example, 'pitchfork is dumb') take a long time to load in Flagging, while it's instantaneous in a browser.

ArchCarrier, Monday, 19 February 2018 13:25 (one year ago) Permalink

Hi. I released a thing with some tweaks. If anyone is encountering bugs with posting, I'm eager to hear about it.

AC, are you loading the pitchfork thread from SNA or bookmarks?

Uhura Mazda (lukas), Monday, 5 March 2018 02:28 (one year ago) Permalink

Thanks for all the work you're putting into this!

- where do I click to go to the top of a thread? (new feature?)

- sometimes, threads just don't load - today, I haven't been able to open "Talking Heads - Classic or Dud?" at all. Spinning wheel & there it hangs forever.
Cleaning cache, restarting phone, uninstalling the app & reinstalling, wifi at work, mobile data everywhere, wifi at home: nothing. And tomorrow (or next time I try, it'll probably just open as if nothing
happened. Okay, it's Android 8.1.0 now, but even when I wasn't in the beta program I had this sometimes.

StanM, Monday, 5 March 2018 15:46 (one year ago) Permalink

For tap to top, scroll up a bit until the thread title appears, then tap it. You can also tap on tabs for SNA / Bookmarks / Boards to go to the top of those lists.

Every thread failing to load (so far) has been the server spitting out XML a little differently than I expected. Will take a look at that one.

Uhura Mazda (lukas), Monday, 5 March 2018 20:47 (one year ago) Permalink

Hmm I see the issue now with threads loaded from bookmarks loading the whole world :( will take a look at that too.

Uhura Mazda (lukas), Monday, 5 March 2018 20:49 (one year ago) Permalink

thanks for your work on this, i use it all the time

It's not delivery, it's Adorno! (upper mississippi sh@kedown), Tuesday, 6 March 2018 20:12 (one year ago) Permalink

^^^

Doctor Casino, Tuesday, 6 March 2018 20:36 (one year ago) Permalink

Okay, I have a comment - when I have my tablet in landscape, I can't bookmark a post - the Send, Browser, Bookmark links are not visible. In portrait mode, they are.
Samsung Galaxy Tab A 8, Android 7.1.1.
The add new post + sign is visible in landscape mode.

neutral yogurt (doo dah), Tuesday, 6 March 2018 21:53 (one year ago) Permalink

Thanks again! that Talking Heads thread loads now

StanM, Wednesday, 7 March 2018 03:35 (one year ago) Permalink

Thanks for looking into the slow loading from bookmarks, lukas!

ArchCarrier, Wednesday, 7 March 2018 08:21 (one year ago) Permalink

There is something in the Ant & Dec s/d thread that makes the Flagging app crash on my android - don't need to fix that for me though, just letting you know in case it's useful

StanM, Monday, 19 March 2018 10:10 (one year ago) Permalink

it happens when I scroll up past that black and white photo

StanM, Monday, 19 March 2018 10:12 (one year ago) Permalink

Just happened to me when I tried it as well.

how's life, Monday, 19 March 2018 10:15 (one year ago) Permalink

fittingly it crashed for me, too

kinder, Monday, 19 March 2018 11:19 (one year ago) Permalink

ironic

Mark G, Monday, 19 March 2018 14:32 (one year ago) Permalink

four months pass...

*peeks head over parapet* anything badly broken? *ducks*

Uhura Mazda (lukas), Friday, 3 August 2018 23:45 (nine months ago) Permalink

not that i've experienced! still invaluable.

(ok i still would love search, FP, browsing your own bookmarks, and find-in-page. but i really ain't complaining, this app is great!)

This is a total Jeff Porcaro. (Doctor Casino), Friday, 3 August 2018 23:58 (nine months ago) Permalink

thanks for making the app! it's great

search is the most obvious thing that would be nice...but...I bet that might be, to use a technical term, a whole nother can of worms so no worries

The Desus & Mero Chain (upper mississippi sh@kedown), Saturday, 4 August 2018 00:26 (nine months ago) Permalink

Yeah, I love this app too, and if search is too hard to include in it, that's okay. Thanks for your work on it!

Tuomas, Saturday, 4 August 2018 11:24 (nine months ago) Permalink

two months pass...

App is still great obv, but long threads still take a long time to load from bookmarks.

ArchCarrier, Monday, 8 October 2018 19:23 (seven months ago) Permalink

Just pushed an update that should fix that.

Uhura Mazda (lukas), Tuesday, 9 October 2018 02:22 (seven months ago) Permalink

The Pitchfork thread (the longest thread in my bookmarks) loads almost instantly, so thanks for the update!

ArchCarrier, Friday, 19 October 2018 07:25 (seven months ago) Permalink

one month passes...

Something in the Shocking plagiarism thread crashes Flagging (as pointed out in that thread), right around this post: Shocking plagiarism

mick signals, Wednesday, 5 December 2018 20:15 (five months ago) Permalink

I'm not gonna have computers for a couple months but I'll look into that (and any other issues that pop up) when i get back

Uhura Mazda (lukas), Saturday, 15 December 2018 20:44 (five months ago) Permalink

two months pass...

Any idea why the Mark Hollis thread is the only thread currently not loading for me on Flagging?

the word dog doesn't bark (anagram), Tuesday, 26 February 2019 22:44 (three months ago) Permalink

The Russian Doll thread doesn't load for me

kinder, Tuesday, 26 February 2019 22:50 (three months ago) Permalink

the hollis thread loads fine for me but i had it bookmarked so idk. could maybe have something to do with the thread title change

diamonddave85​​ (diamonddave85), Tuesday, 26 February 2019 23:27 (three months ago) Permalink

I dunno if this is fixable, but if I've bookmarked a post in a thread with hundreds of posts, and the bookmarked post is not among the most recent posts, rather than among the posts the app automatically hides, when I click on the bookmark the app doesn't jump to the bookmarked post. Instead it just shows the most recent posts, and I have to keep on clicking the "load 100 earlier messages" until I find the bookmarked spot.

Tuomas, Tuesday, 12 March 2019 11:06 (two months ago) Permalink

Yeah i've had that too, when threads are really going nuts.

|Restore| |Restart| |Quit| (Doctor Casino), Tuesday, 12 March 2019 11:48 (two months ago) Permalink

hmmmmm

lukas, Tuesday, 19 March 2019 02:36 (two months ago) Permalink

Somehow I only just found this app. (Serves me right for rarely straying from ILM.) Looks good. Please excuse this one boring test post...

Nag! Nag! Nag!, Tuesday, 19 March 2019 08:18 (two months ago) Permalink

This is the ILX APIs fault: it only serves up the most recent 100 posts for a bookmark unless you tell it to page. I’m looking into fixing it

stet, Tuesday, 19 March 2019 08:19 (two months ago) Permalink

It's not working for me atm

kinder, Sunday, 31 March 2019 22:43 (one month ago) Permalink

Not working in what way? If you just get an endless spinner, try closing and reopening the app.

lukas, Monday, 1 April 2019 01:58 (one month ago) Permalink

I had several "server not responding" messages from theporouscity yesterday (both AM and PM) but I figured patches or upgrades were being done and it worked again a bit later every time

StanM, Monday, 1 April 2019 02:18 (one month ago) Permalink

Yeah that but it's ok now

kinder, Monday, 1 April 2019 07:51 (one month ago) Permalink


You must be logged in to post. Please either login here, or if you are not registered, you may register here.